Jump to content
Maximundo

Need help with wireless camera project

Recommended Posts

This camera system was found on e-bay it was only $44,99 SH included. According to the advertisement and the owners manual it’s operating frequency band is 2.414 to 2.468 GHz. I bought it to attach to a TC3 1/10 scale RC car and to possibly improve its performance.

The camera circuit is attached to the audio and video transmitter by only a three-element wire. +5v, -5v and video. I tried to transmit a video signal from a hi8 Sony camcorder but the picture looked like it was scrambled. I’m not sure if I could use a higher resolution camera or not. So I’m asking for advice on modifying video signals from higher resolution sources or what type of board camera would work with this transmitter and receiver system.

The last two pics are from the transmitter via receiver video out. The first of the last two is from the included camera; the last one is from the Sony hi8 camera. (the ps (page shot) in the pic name is the smaller file.)

I tried to set this post up with HTML to show all the smaller pics using <A href> to the larger pics but unfortunately the forum doesn’t recognize HTML. Can someone explain why?

http://photos.imageevent.com/maximundo/ebay//cam1.jpg http://photos.imageevent.com/maximundo/eba...bay//cam1ps.jpg

http://photos.imageevent.com/maximundo/ebay//cam2.jpg

http://photos.imageevent.com/maximundo/eba...bay//cam2ps.jpg

http://photos.imageevent.com/maximundo/ebay//cam3.jpg

http://photos.imageevent.com/maximundo/eba...bay//cam3ps.jpg

http://photos.imageevent.com/maximundo/ebay//cam4.jpg

http://photos.imageevent.com/maximundo/eba...bay//cam4ps.jpg

http://photos.imageevent.com/maximundo/ebay//cam5.jpg

http://photos.imageevent.com/maximundo/eba...bay//cam5ps.jpg

http://photos.imageevent.com/maximundo/ebay//cam6.jpg

http://photos.imageevent.com/maximundo/eba...bay//cam6ps.jpg

http://photos.imageevent.com/maximundo/ebay//cam7.jpg

http://photos.imageevent.com/maximundo/eba...bay//cam7ps.jpg

When you want to drive up in a Cadillac and the host only allows dodge K-cars you hope it’s not a trend.

Share this post


Link to post
Share on other sites
tried to set this post up with HTML to show all the smaller pics using <A href> to the larger pics but unfortunately the forum doesn’t recognize HTML. Can someone explain why?

You must use IBF coding, not HTML. These codes work similar to HTML. Just click on the BB Code Help Link that is shown in the reply window (found under the Clickable Smilies icons). Or, use the shortcut buttons in the reply/edit window to automatically insert the tags.

http://www.rc-cam.com/forum/index.php?show...&st=0entry557

Share this post


Link to post
Share on other sites

The first thing I would test is to see if that CMOS board camera is putting out a standard video signal.

Hack together a cable that you can use to apply power to the camera, and then examine the video signal on an o'scope. There are some good pictures on the 'net' of what a reasonable looking video signal will look like.

If you are the adventurous type type (or you don't don't own an o'scope) you can plug the video signal from the cmos camera into your tv or vcr. If you cannot see a picture or the picture is scrambled, then it appears the unit is not working with a standard composite video signal.

Let us know your results!

Bill

Share this post


Link to post
Share on other sites

Yb2normal's responses are spot on.

BTW, is there any chance you had the camera's video wiring reversed at the Sony's input? Inverted video polarity will be very goofy looking.

Share this post


Link to post
Share on other sites

Mr. RC-CAM is the MAN:

“is there any chance you had the camera's video wiring reversed at the Sony's input? Inverted video polarity will be very goofy looking.”

Yes, behold:

http://photos.imageevent.com/maximundo/ele...cs//hi8set2.jpg

http://photos.imageevent.com/maximundo/ele...cs//hi8daz2.jpg

What I had labeled, as video should have been connected to the shield element of the video signal and –5v were for the shielded center element. Just a simple reversal was all it took.

So my next questions are how do I integrate a board camera to a 3 element TX with specifications like this:

External Terminals: ----- 6-pin cable connector

(1)Power input

(2)GND

(3)Video output

(4)GND

(5)I²C SCL

(6)I²C SDA

Much much mahalo

Share this post


Link to post
Share on other sites

(1)Power input: To DC Power (usually 5VDC).

(2)GND: To DC Power Gnd

(3)Video out: To Video Input of Tx.

(4)GND: To Video Gnd.

(5)I²C SCL: Not used.

(6)I²C SDA: Not used.

The pinout you show looks like it is to a Panasonic camera. There are basic examples of wiring these sort of board cams in the RC-CAM3 & RC-CAM4 projects.

Share this post


Link to post
Share on other sites

Yes the Specifications

are from Panasonic’s GP-CX161 @ rock2000.com. I’m considering buying a GP-KX121 or maybe a GP-CX171

but have concerns about my TX’s built in dc-dc converter. With the existing camera and TX set-up, it’s using 250ma. Without the camera it’s pulling 200ma. So the existing camera is only using 50ma but the GP-CX161 uses 130 mA at 5 Volts. Also Min Illumination is 5 Lux @ F2.6. The existing camera’s usable illumination is only 0.5 Lux, not sure what the lens aperture or focal Length

is on it.

Anyway right now I’m just evaluating the potential of my TX-Rx system and wireless video transmissions on RC devices. Up to now it’s a fun, high Tec amusement.

Current progress:

http://photos.imageevent.com/maximundo/ele...cs//tc3cam1.jpg

http://photos.imageevent.com/maximundo/ele...cs//tc3cam2.jpg

http://photos.imageevent.com/maximundo/ele...cs//tc3cam3.jpg

Thanks for putting up your RC-CAM projects. They were inspiring.

Share this post


Link to post
Share on other sites

Hi there.

I see from your last photo posted that you are currently using the camera that came with the system. Is the video quality garbage as is the case with X10's or is it at least half decent?

Thanks much

Dee

Share this post


Link to post
Share on other sites

http://photos.imageevent.com/maximundo/ebay//cam6.jpg

This is what it looks like under a 60watt incandescent light. The picture can look sharper than this using the TC3’s movement to focus instead of monkeying with the dial on the camera. Bright light will knock it back to the 60s and put it in a purple haze. Yesterday I brought the set up down the street a couple blocks to try to evaluate the long-range video transmission quality. The sun was waxing and waning (in and out) and the video was pure rainbow city. The camera is definitely not for out doors. But when testing it indoors by placing the receiver with its original antenna on top of, and connected too my 20 inch Sony trinatron, then driving the TC3 out the door and down the hall and into the living room, it works very well. Even if I leave the front door open and drive the TC3 up to the threshold, the outdoor image comes in pretty good. I’m going to try a shade around the lens and see if that helps reduce the rainbow smear effect.

Share this post


Link to post
Share on other sites

On second thought instead of a shade maybe a different lens. I took a lens out of a Ezonics web-cam and it fit. But it just happened to be the same focal length and probably the same aperture size.

I noticed a web sight that sells lenses for board cameras. I haven’t checked yet but if I can find one with a high F-stop number (small aperture, wide depth of field), and a suitable focal length, I may solve the color smear problem. And end up with a lens that keeps everything in focus.

Share this post


Link to post
Share on other sites

Well I haven't found a suitable shade for the camera but I can almost guarantee that with a good shade, outdoor video images will be improved. As the camera is, the first glass filter or lens is very convex and bulges almost out of its housing. Any bright light that strikes it on a sharp angel is bound to interfere with light coming in directly.

Anyway the camera is installed in a Tamiya Blackfoot body I picked up a couple of weeks ago. I only paid a buck for it so drilling holes in it was no problem. Come to find out the body has considerable value on e-bay. But as it stands now, I'm happy with the camera set up in the Tamiya Blackfoot body on a TC3 chassi. It works well indoors and the TC3 chassi is to low for outdoor operation, unless on a very smooth surface. Driving it in the street chews up the bottom. And although silicon was used to lock the camera in, it's sort of a done deal already.

Current content progress:

http://photos.imageevent.com/maximundo/ele...ackfootcam1.jpg

http://photos.imageevent.com/maximundo/ele...ackfootcam2.jpg

http://photos.imageevent.com/maximundo/ele...ackfootcam3.jpg

http://photos.imageevent.com/maximundo/ele...ackfootcam4.jpg

http://photos.imageevent.com/maximundo/ele...ackfootcam5.jpg

I did buy a Traxxas Bandit and have thoughts of installing a different camera in it.

The buggy is much more capable of outdoor adverse driving conditions so a camera like-wise would be nice.

Next project:

The Waikiki beach bugger.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×