Jump to content

Recommended Posts

I would like to install a microphone on my 2.4Ghz and 900Mhz video transmitter systems. I would like to know if anyone has done this and if so where did you get your microphone and how did you connect it.

I like to monitor the electric motor in flight and this aids in letting me know the status of the flight.

ANY assistance would be appriciated.

I know that you can buy plug and play systems with the mic already installed, but I have my systems already and would like to add this feature.

Thanks C-YA RL

Share this post


Link to post
Share on other sites

I think you probably got your answer on RCG but here it is again. Check out www.rangevideo.com he sells them for about $12 and they connect to any TX that supports audio.

Share this post


Link to post
Share on other sites
I think you probably got your answer on RCG but here it is again. Check out www.rangevideo.com he sells them for about $12 and they connect to any TX that supports audio.

Thanks for the response, but the mics that I see already installed on the plug & play units don't have the amplifier on the end like that one does. I have purchased 1 of these mics sold by Range Video from SuperCircuits and I was unable to get it to work, so I am asking for additional information on the mics used and installation of the same.

Thanks again.

C-YA RL

Share this post


Link to post
Share on other sites

Either defective units or installed wrong,

did you get a good how to connect or how to use guide ?

why not ask the shop ? theu should know their products and support the customers, we cant know all products, but we normally try to help as much as possible, specially when the questions relate to items we use our self,

then we might even know more than the shops and also answer faster :-)

good luck

Share this post


Link to post
Share on other sites

Thanks for the response, but the mics that I see already installed on the plug & play units don't have the amplifier on the end like that one does. I have purchased 1 of these mics sold by Range Video from SuperCircuits and I was unable to get it to work, so I am asking for additional information on the mics used and installation of the same.

Thanks again.

C-YA RL

Ooooo SuperCircuits you say? I've read too many threads here and there where these guys are not very good at customer support. They almost never respond back to any emails or phone calls. I hope I'm wrong but best of luck in your solution!

Edited by JMS

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×