Jump to content
Sign in to follow this  
Alvaro

LOMA with DX7 radios

Recommended Posts

This tips is for all that use the LOMA in the DX7 radios with receiver AR7000. The AR7000 have the failsafe only on the "throttle" channel. Others channels have the "HOLD" position, it retain the servo position on loss of signals. So...adjust the Travel Adjust for the THRO on 150% on "Low" position and connect the LOMA on this channel with Y Cable. Readjust the setup for your model using this travel adjust.With this adjust the LOMA work very well with Spektrum DX7. :D

Share this post


Link to post
Share on other sites

Yes, it work with DX7 radios, you need to connect on the throttle servo by one Y cable and set te ATV to 150% on Low side, this is the only channel that the failsafe work, others channels not have the failsave function , it retain the last position on servo (mode HOLD). For this reasons many people have problems with LOMA on DX7....But it work very fine. :D

Share this post


Link to post
Share on other sites
This tips is for all that use the LOMA in the DX7 radios with receiver AR7000. The AR7000 have the failsafe only on the "throttle" channel. Others channels have the "HOLD" position, it retain the servo position on loss of signals. So...adjust the Travel Adjust for the THRO on 150% on "Low" position and connect the LOMA on this channel with Y Cable. Readjust the setup for your model using this travel adjust.With this adjust the LOMA work very well with Spektrum DX7. :D

ited what u said to set the atv on 150% and it dont work, what am i during wrong ??

Share this post


Link to post
Share on other sites

Alvaro is the expert on this, so hopefully he joins in. But, did you rebind the receiver (see page 19 of DX7 manual) after you made the T-ADJ menu changes on the Tx? Binding is needed whenever failsafe settings are altered. Beyond that, I can't help since I don't have a DX7 / AR7000 system.

Share this post


Link to post
Share on other sites

Yes, after this adjust on the new setup you need to make a new rebind. When the radio is off the alarm go on....and the thottle is on the iddle position (failsafe mode). Work fine the LOMA.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this  

×