Jump to content
Sign in to follow this  
Crash9

What's The Deal With My 900mhz Tx

Recommended Posts

I purchased 2) 500 mw 900mhz TX from Supercurciuts. One has normal range at 1 mile plus but the other one only goes 1000 ft before it drops out. I also noticed when I power it up on channel 1 the signal disappears after 3 minutes (after warms up) and if I switch to Channel 2 on the RX the video signal shows up there. The TX is set on channel 1 but the RX is on 2. I have to go through this everytime I use it.

Any help. Thanks :)

Share this post


Link to post
Share on other sites
I also noticed when I power it up on channel 1 the signal disappears after 3 minutes (after warms up) and if I switch to Channel 2 on the RX the video signal shows up there.

Odear, sounds like the TX is not crystal controlled. I had a cheap 2.4Ghz camera and TX that did the same, the only way I could use it was to connect it 5 min before I took off. A better quality TX is the best way to go.

I would also expect much more than 1 mile with 500mW at 900Mhz unless you have a dipole on each end ?

Terry

Share this post


Link to post
Share on other sites

Yeah I agree Kilrah, There both the same units that everybodys is selling for FPV I just get them from SC. I'll be sending this one back and hope they'll give me a replacement :) .

Edited by Crash9

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this  

×