Jump to content

Attention: RC-CAM.com will be closing down August 2021.

The RC-Cam.com forum was the very first online community dedicated to the advancement of wireless video cameras on radio controlled (R/C) models. This is now called "FPV" (First Person View). We are proud of the contributions that our members have made to the FPV hobby.

We've seen significant changes over the last twenty years. Initially there were a lot of eager R/C hobbyist that built their own video systems. Allowing these creative individuals to share their work was the purpose of this site. Now the FPV market is flooded with low cost systems; Sadly DiY FPV video projects are now rarely discussed.

RC-CAM.com (main site and forum) will be closing down August 2021. This was announced several months ago (March 2021) to allow our members ample time to download any information that is important to them. After the site is shutdown the information will no longer be available here.

We appreciate every member's involvement with advancing the FPV hobby. It is indeed sad to say goodbye to all our online friends. Be safe and stay healthy.



Blackstork GPS problem


Recommended Posts

Been experimenting with FPV the past 6 months but have lost a sailplane and nearly lost a T-Rex 600.

Now I bought the Blackstork OSD and mounted it with 2 channels controlling the menus. Everything works fine except that it never gets any GPS information. It just says ´starting GPS´ and keeps counting. Is this a common problem. Tried two different GPS modules but with no luck. Can anybody please help me? /Claes.

Link to comment
Share on other sites

2 things come to my mind:

I just recently saw someone mentioning 2 different BS cards that would not supply any power to the GPS module. Might be good to check with a voltmeter if power is present on the GPS connector.

The second one is related to the video TX - I see it's working on 1.3GHz, it might be swamping the GPS frontend. Try putting it as fas as possible once on a test setup, or even to use the camera/OSD directly hooked to a monitor without the TX being powered to see if it helps.

Link to comment
Share on other sites

I agree with Kilrah, there is a good chance the video Tx's RFI is affecting the GPS reception. Besides directly connecting the OSD to the monitor to eliminate the video Tx link, here is a short-cut test if the GPS module has a status LED on it:

Go outside, in clear view of the heavens. With everything running, watch the status LED for several minutes and confirm that it reports no satellites can be found.

Next, remove power from the Video Tx and then wait several minutes to see if the GPS's status LED shows that it has found satellites. If it does, then you know the Video Tx's strong RFI is a big part of the problem.

Link to comment
Share on other sites

Thanks for all the help. I´m going to measure the voltage on the GPS module. Already tried to connect the video glasses directly to the OSD, eliminating the video TX. How about the Futaba 2.4GHz? Could it interfere with the GPS? The Blackstork won´t start without the two rc channels connected so I havn´t tried without 2.4GHz tx. Is there any other good OSD on the market? The problem with the Blackstork also seems to be that there is no help to get from the manufacturer or from hobbywireless. /Claes

Link to comment
Share on other sites

I had the same problem with the Blackstork GPS when I first installed it on an Easystar a couple months ago. The manual said something about this happening and suggested playing with the wiring to correct the problem. After randomly re-routing all my wiring and double-checking all the connections it worked. Not sure what the specific problem was but at least I was able to get it working. For what it's worth I have the GPS wire lead as isolated as possible from all my other wiring. I'm really new at this so keep in mind that my comments and advice might not be worth all that much!

Link to comment
Share on other sites

How about the Futaba 2.4GHz? Could it interfere with the GPS?

The nearby 2.4GHz R/C receiver will not interfere with the GPS signal. Keep the R/C Tx away from it though.

The Blackstork won´t start without the two rc channels connected so I havn´t tried without 2.4GHz tx.

If the BSOSD needs both R/C channels to start it then that is interesting. Maybe the GPS problem is due to the unique servo signal order on the Futaba 2.4Ghz system? Do you have another R/C system to try?

Link to comment
Share on other sites

  • 6 months later...

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

×
×
  • Create New...