Jump to content

Wireless A/V Receiver SAW Filters: What's this all about?


Recommended Posts

I just use the freq gen to find the -3dB points. The frequency that these occur at will depend on the video link's performance. On the test system the high end was measured at ~4.9MHz before and after the SAW upgrade.

I always use a composite video generator to set the video levels. All my A/V systems get this tweak (the mfg's factory adjustments are not reliable).

I've also seen a lot of variation in the mfg's factory settings. Using a 2.33 Mhz input to set the Bessell null is quite nice since it does not require a composite video generator and "standard" receiver so there are less variables in the process.

One more question and I'll stop pestering you. Have you tried pre-emphasis/de-emphasis for an improved S/N?

OMM

Link to post
Share on other sites
Have you tried pre-emphasis/de-emphasis for an improved S/N?

I indeed have been working on that. Custom PC boards are built and partially debugged. My gut feeling is that using it with the SAW filter will double the range on a 900MHz - 1.3GHz system. Fingers are crossed!

Link to post
Share on other sites

I indeed have been working on that. Custom PC boards are built and partially debugged. My gut feeling is that using it with the SAW filter will double the range on a 900MHz - 1.3GHz system. Fingers are crossed!

6 dB is what I would expect too. I hope your results are better than mine. I just did not see the expected improvement but I did it rather quickly with passive filters on the TX and RX. It is possible that I made a mistake in the build and/or test. I'll be interested in hearing your results and may revisit mine later this week.

OMM

Link to post
Share on other sites

6 dB is what I would expect too. I hope your results are better than mine. I just did not see the expected improvement but I did it rather quickly with passive filters on the TX and RX. It is possible that I made a mistake in the build and/or test. I'll be interested in hearing your results and may revisit mine later this week.

OMM

Great minds think alike? I was just about to solder in these pre/deemphasis networks and do some further measurements. Unfortunately I'm still waiting for my SAW filters to arrive, but once they do I'll be doing the same measurements both of you have done. I've flown out to >4km with a 500mW 1.2GHz (1180MHz) Tx (http://www.vimeo.com/8715397), which shows plenty of link budget left at that distance (RSSI values noted are for the EzUHF RC control link, but video is crystal clear). Since then I've plotted the RSSI curve and verified the signal levels actually reflect a useable image and am confident that with an omni (0dBi) on the Tx and a 8dBi flat patch on the Rx I should be seeing >10km of range, if these SAW filter and pre/deemphasis mods work out that should about double.

Cheers,

Sander.

Edited by ssassen
Link to post
Share on other sites

Great minds think alike? I was just about to solder in these pre/deemphasis networks and do some further measurements. Unfortunately I'm still waiting for my SAW filters to arrive, but once they do I'll be doing the same measurements both of you have done. I've flown out to >4km with a 500mW 1.2GHz (1180MHz) Tx (http://www.vimeo.com/8715397), which shows plenty of link budget left at that distance (RSSI values noted are for the EzUHF RC control link, but video is crystal clear). Since then I've plotted the RSSI curve and verified the signal levels actually reflect a useable image and am confident that with an omni (0dBi) on the Tx and a 8dBi flat patch on the Rx I should be seeing >10km of range, if these SAW filter and pre/deemphasis mods work out that should about double. If that all holds true, all that is left for me to do is to make a custom 1.2GHz 500mW Tx design which uses the ATV channels so can be legally used by HAMs.

Cheers,

Sander.

Hi Sander,

Nice 1.28 Ghz video signal at that range. I've been approaching the omni coverage issue a bit differently as you can see here:

http://www.rcgroups.com/forums/showthread.php?t=1147430

You can also see my new antenna design on page 7 of that thread which provides a circular polarized omni with a 20 dB LHCP to RHCP ratio over the entire radiating sphere. This allows much reduction of multipath distortion/loss which is a problem for long distance, low height quad copter flying.

OMM

Link to post
Share on other sites
I'll be interested in hearing your results and may revisit mine later this week.

Update: A bit disappointed, but not discouraged. I finished up the measurements today and sadly must report that the pre-emphasis trickery does not improve my 900Mhz test system.

I suspect there is a non-standard pre-emphasis network already in the system I tried it on (900MHz/500 mW Tx and Rx, www.dpcav.com). However, this should not stop anyone from continuing on the quest since there may be some A/V systems that would benefit from something like this.

Below is a photo of the project (pre-emphasis board on Tx, de-emphasis board on Rx). Both boards had video level compensation to ensure proper amplitudes through the emphasis circuity. Also, active buffer-amps in the video chain ensured that the LC networks saw exactly 75 ohms, regardless of what was connected to them.

post-2-126403180481_thumb.jpg

In case there is any possible confusion from the casual readers: this pre-emphasis stuff has nothing to do with the original topic's SAW filter modification. So, I apologize for pushing the discussion off-topic.

Link to post
Share on other sites

Update: A bit disappointed, but not discouraged. I finished up the measurements today and sadly must report that the pre-emphasis trickery does not improve my 900Mhz test system.

I suspect there is a non-standard pre-emphasis network already in the system I tried it on (900MHz/500 mW Tx and Rx, www.dpcav.com). However, this should not stop anyone from continuing on the quest since there may be some A/V systems that would benefit from something like this.

Below is a photo of the project (pre-emphasis board on Tx, de-emphasis board on Rx). Both boards had video level compensation to ensure proper amplitudes through the emphasis circuity. Also, active buffer-amps in the video chain ensured that the LC networks saw exactly 75 ohms, regardless of what was connected to them.

post-2-126403180481_thumb.jpg

In case there is any possible confusion from the casual readers: this pre-emphasis stuff has nothing to do with the original topic's SAW filter modification. So, I apologize for pushing the discussion off-topic.

Well, that makes me feel a little better about my test with the passive filters. I had wondered if an active pre-emphasis & de-emphasis would do any better but did not want to put the effort into it. Those are VERY nice looking PWBs and it is a shame that the results were not better.

It does make me wonder why we did not see the improvement.

OMM

Link to post
Share on other sites

Well, that makes me feel a little better about my test with the passive filters. I had wondered if an active pre-emphasis & de-emphasis would do any better but did not want to put the effort into it. Those are VERY nice looking PWBs and it is a shame that the results were not better.

It does make me wonder why we did not see the improvement.

OMM

I can confirm that the pre/deemphasis doesn't really pay off. I couldn't see any increase in sensitivity or noise levels that would stand out from the margin of error in the test configuration. The SAW filter upgrade however did pay off nicely. I've seen a nice 4 tot 5dB sensitivity increase with a sampling of two receivers modified (BSS479 type). I did however do away with the whole baseband video decoding and reworked that entire part of the circuitry after some extensive modelling in LTspice. I now have video quality that's indistinguishable from the best 2.4GHz receivers I have here. The audio portion is next, but that requires a little more effort.

Ps. getting the SAW filter out was a piece of cake in my experience. Use solder wick to remove solder on the input/output pins and make sure they can move freely inside the hole. Use a soldering iron >50W for the ground pin with a broad/flat tip. Heat the ground pin and with a small screwdriver (slightly larger than the pin) just push the pin down after a few seconds of heating the pin. That'll pop the SAW filter right out without any effort!

Cheers,

Sander.

Link to post
Share on other sites
  • 10 months later...

I have replaced the saw filters in 900 MHZ RX. Before the swap out, I have noticed at distance 2 miles + some noise possible from transmitter close to frequency I was on. Now eliminated with the ECS-D480A New saw filter. Works old was F 480 2

Edited by lvsupertech
Link to post
Share on other sites
  • 1 month later...
  • 2 months later...

Made a little video showing my method of removing the SAW filter from these A/V receiver modules.

I know some folks may think this a crude method...

but I find this method very easy to do, and this has worked for me every time on the 6 Rx's that I have modded so far.

The Rx in the video will be the 7th one I have done, and it is now all back together and working just fine.

Edited by galaxiex
Link to post
Share on other sites
  • 9 months later...

Updated Information:

I received some 8MHz SAW filters a few days ago. With my fingers crossed, I was expecting that they would provide additional performance over the prized 17MHz SAW filters. But sometimes things don't work as planned; To my surprise they reduced the stock Rx's sensitivity by -5dB. The unmodified Rx's measured -85dBm was reduced to -80dBm with the new 8MHz SAW.

The most notable thing that may explain the disappointing results is that the new filters are characterized for 50Ω in/out. The 17MHz ECS-D480A filter is 70Ω in / 280Ω out. So the different impedance may be the reason for the poor results. But that's just my best guess at the moment.

I didn't take the time to determine if the reduced SAW bandwidth was helpful in rejecting interference from adjacent frequencies. So you never know, they may have an upside.

If anyone wants some ridiculously hard-to-find parts then I have some new 8MHz SAW filters I will sell. I don't need them. :)

The basic setup

post-2-0-78746900-1330047314_thumb.jpg

Link to post
Share on other sites

It's hard to guess these things. The 280Ω spec might have been decided by the SAW filter designer because it was convenient or perhaps it was deliberately requested by the receiver designer based on the circuit impedance of a proposed IF filter circuit. I'm more surprised that the new SAW was 50Ω since raw components tend to be everything but that. :)

Link to post
Share on other sites
  • 2 weeks later...

....The basic setup

post-2-0-78746900-1330047314_thumb.jpg

I'm quite suprised that you would have a test layout like that. The amount of leakage would be so bad that any test results would be suspect. While I don't doubt the possibility that the new SAW filter's 50 ohms vs 280 circuit design would provide a poor result, you really can't base it on that test. Using the TX as the signal source for evaluation of RX sensitivity would require that it be mounted in a completely shieded box with filtering on power and video lines. The first attenuator would also have to be mounted within that box. I've done quite a bit of testing to prove this as has been previously discussed in this thread:

http://www.rc-cam.co...ignal-with-osd/

I'm just trying to be helpful here and hope you understand no disrespect is intended. You certainly are one of the most helpful R/C technical contributors on the net

OMM

Link to post
Share on other sites

No problem to criticize, no harm in that. I admit that the test setup is cheap and dirty. RF leakage issues are expected but they are not to blame for the reduction in the Rx's sensitivity when I installed the new SAW filter.

FWIW, immediately after the disappointing 8MHz filter tests I installed a 17MHz filter and the results were about +2dB better than the original stock 27Mhz filter. So even if the absolute readings are tainted by RF leakage, the relative sensitivity changes between the various SAW filters is the data I wanted to observe. If you would like to test a 8MHz filter to confirm the test results then please contact me via PM and we can work it out. Especially since there's so many different tuner models in circulation that it may be possible to find one that likes this 8MHz SAW.

Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

×
×
  • Create New...