Jump to content
Sign in to follow this  
iwik

9X R/C Flysky RF Module High Throttle on Power Up

Recommended Posts

Hi Thomas,

Further to the comments and tips you gave me.

I diconnected PPM input to RF Module and tried,

1. Tying it to GND

2. Tying it to 3.3v.

3 Leaving it floating.

The servos in all cases still received these pulses.

I took the rf module out of one radio( not experiencing the problem) and put it into the other one.

This one now works correctly.

Both of my radios have updated f/w. One has Open9x/er9x and the other has Ersky9x.

So to me it looks like the Flysky modules f/w has been changed.

Good to see your radios are experiencing the same problem.

When i scope ppm input on both of my radios with the stock flysky rf modules the ppm line is the same.

Its just one rf module seems to be sending some data to the receiver which outputs 1ms pulse immediately power is applied.

As you are more Advanced in the possible fixes,would you mind adding your comments to the 9x

forums on this issue.

Thanks

Les

Have pm u re Module.

Edited by iwik

Share this post


Link to post
Share on other sites
I took the rf module out of one radio( not experiencing the problem) and put it into the other one. This one now works correctly.

That is bad news. It appears that the RF module design has changed. Does a stock 9X with original factory software have the problem?

... just one rf module seems to be sending some data to the receiver which outputs 1ms pulse immediately power is applied.

Actually, it would be ideal if it was sending 1mS since that is a common throttle-off timing. However, I measured the unwanted pulse on my FlySky 9X and it is 1.5mS before the splash screen. This timing is is mid-throttle stick!

Unless someone comes up with an easy workaround, at this point the only solution would be in the software; It needs to initialize the PPM signal immediately during boot startup, long before the splash screen and other tasks.

My FrSky 9X does not have this issue. Given all the advantages of the FrSky Telemetry RF module upgrade, maybe it is the best solution to this problem.

Share this post


Link to post
Share on other sites

Thomas,

Yes to go Frysky is really the best answer. I have the diy DHT module to fit and are going to follow your hack to complete this

along with building the Hub you designed.

I agree the best solution is to output PPM at boot and Mike says that he would have to use valuable memory space to do it.

In his case he has a twin and thinks its going to be goble up to much memory.

I get 1.5ms pulses when you first boot and consequently the motor is dangerous if model is live.

I havent tried a stock 9x with original software. Although i intend swapping the modules back and then may load

original software and see what happens.

Thanks for your input. I was not to worried about it as both of my radios will be fitted out with Frysky Telemtry soon.

Les

Share this post


Link to post
Share on other sites

Upgrading with FrSky's RF system is a very good solution. Especially since you plan to add the 9X voice feature.

Share this post


Link to post
Share on other sites

Thomas,

I did load original f/w and the stock radio did the same thing but the time the 1.5ms was available was very short.

I think Mike is going to do something about sending ppm pulses at p/u.

Les

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this  

×