Jump to content

Recommended Posts

Hi!

It seems that i have killed my FR632 today by clymsy soldering, when trying to mod it to get rid of the synk problem. Now it's not starting at all. Nothings happen when i plug the battery in and press the power button. I have measured that the battery voltage reaches the power button, and I have also measured that the power button closes circuit when pressed down, but there my ideas of trouble shooting are stuck! Do anyone here have idea what to do? :unsure:

Here what I have done and when the problem arrived:

1.  

  • I desoldered the transistor descibed abobe an bridged it to lower connection points in the PCB.
  • I removed the drain resistor.
  • Accidentaly I also destroyed the component (resistor?) to the left of the transistor, and also got som solder on to component (capacitor?) above transistor. I don't think it's a short circuit there.
  • Anyway, after this i tried the receiver and i was working much better than before. But the sync problem was not completely gone.

2.   

  • I tried to remove the bridge over the transistor and put a capacitor there. 100uF was the largest i had, to I used that.
  • When trying to power up not, it's dead.

3. 

  • I removed the 100uF cap and but bridge back again. And it's still dead.

 

Thanks in advance if anyone has any trouble shooting tips!!

 

fr632-misstake.jpg

Edited by holger

Share this post


Link to post
Share on other sites

The best troubleshooting tool is your eyes. So BEFORE you do anything more, clean up your rework with alcohol or flux remover. Your soldered areas should be free of flux, same as the factory work you see elsewhere on the PCB. Clean looking rework will allow you to do better visual inspections.

After the flux cleanup, get out a magnifying lens and inspect for solder shorts in your rework areas. Use a ohmmeter to confirm any suspicious soldering.

The trace that is common to both the yellow and red circled areas is connected to the 3.5V supply. I suspect it is/was shorted to ground (both areas have messy soldering and may have a solder short). If solder shorting has occurred then the 3.5V power supply may have been damaged. But assume the best, clean up all your reworked soldering, and retest.

If necessary, remove your jumper wire and tidy up the soldered areas. Don't re-install any of the old components and ignore the missing parts. After a careful visual inspection, try to power up the vRx. The goal here is to eliminate any possible power supply shorts in the rework area. If that solves the power issue then you will know the 3.5V supply is Ok and you can proceed to re-install the mod.

BTW, if you decide to add the video coupling cap then be aware 100uF is much too small for proper sync fidelity. Your undersized cap has nothing to do with your power supply issue, but assuming you get the vRx working you will want to use the proper value cap.

  • Like 1

Share this post


Link to post
Share on other sites

Thanks allot for your help, after I cleaned up and removed the bridge, the vRx started up again :). Maybe I will have more questions when I continue with the mod. Need to get a larger cap first.

Share this post


Link to post
Share on other sites

Just wanted to say thank you for this thread.. My fr632 was working with various level of success with different vtxs, luckily I had others to fall back on, now I have a clue about why/how it is how it is. Thanks esp Mr RC Cam

Share this post


Link to post
Share on other sites

Hi,

I installed a fr632 rx 40ch from this quanum bundle https://hobbyking.com/en_us/quanum-fpv-bundle-set-with-600tvl-camera-600mw-transmitter-and-40ch-diversity-receiver.html/?___store=en_us In a eyebox goggles http://www.eyeboxfpv.com/eyeboxfpv7 . I got my goggles long time ago before the manufactured had 40 ch diversity rx instaled  from factory.

I got blue screes quite often  an this situation is accentuated when I am flying with other nearby racing  quands, the range is hardly 100 m. I have tried different frequencies and  several  brands and desings antennas  and I can not get this problem solved. I do not know if it can be an impedance compatibility problem or whatever.

Before leaving the goggles abandoned in a drower I would like  to try some modification like the one commented in this thread.

I have also found this other implemetation https://www.rcgroups.com/forums/showpost.php?p=35696581&postcount=1444 installing  a lower  rated  cap in a different place .

 I do not know if doing one of those implementations will resolve the problem but I think they wiil not do more harm than I already got ., I have already losen two quads.

Which one do you recomend to try first if any of those could hep?

Any recomendation or help would be appreciated.

Thks

Share this post


Link to post
Share on other sites
Quote

Which one do you recomend to try first if any of those could hep?

I recommend doing the mods discussed here.

 

Share this post


Link to post
Share on other sites

FWIW, video level issues, like the bad FR632 vRx in this discussion, affect other FPV systems too. Not everyone recognizes that their video image's problems are due to incorrect video levels; Instead they blame other things. The only way to know if the video level is correct is to measure it. That's easier said than done!

The problem is caused mainly by the lack of respect for the composite video standards. These industry documented specifications are often ignored to save manufacturing cost, other times it's due to the ignorance of the video circuit designer. Our cheap imported FPV products have been big offenders of this.

To help combat the problem I've created a DiY built tool to check the video levels. It can also be used to calibrate the video level. The project is simple to build and replaces expensive/complex test equipment. Any FPV hobbyist that cares about their video signal level can now easily check it.

Details are published here: https://www.rc-cam.com/forum/index.php?/topic/4126-diy-fpv-video-calibration-tool-low-cost/

Full_Assy1_1000.jpg

Share this post


Link to post
Share on other sites

Hi there.

stumbled into this thread while googling for potential issues of this receiver.

I never thought my receiver would have problems, but I’ve noticed a different image between my googles (FR632 40channels paired with a Quanum V2 headset) vs. some Eachine diversity headset.

Still not sure if the issues are related to the antenna or some other cause, but I dont experience the issues described in the OP. I only have some noise... some horizontal lines that dont appear on the Eachine receiver.

Anyway... another question, would be possible to add a minimosd directly to the FR632 and display some lines with the signal strength like other goggles do? I know for example that miminosd gives some kind of percentage for RSSI but I would like bars like the rest of googles that can do that?

Also, adding a DVR recording inside would be nice as well, dont think about an external unit.

Share this post


Link to post
Share on other sites
Quote

would be possible to add a minimosd directly to the FR632 and display some lines with the signal strength like other goggles do?

Look for DiY vRx OSD applications by searching for projects like this: https://dronegarageblog.wordpress.com/2016/01/20/arduino-5-8ghz-rx5808-module-open-source-fpv-receiver/

Share this post


Link to post
Share on other sites

I’ve done the mod described in previous posts, I’ve removed the thing with 3 legs, the 75 ohm resistor and soldered a 470uF capacitor (I had only low ESR type ones).

Pic attached.

Preliminary testing seems I got rid of the screen tearing and image skewing when changing rapidly from dark to light on camera.

 

4A8BF08A-54D6-44F4-948A-D3BF34AA9835.jpeg

Edited by Arise

Share this post


Link to post
Share on other sites

Question is... I still got 0.75V output on the other 2 outputs, on the bottom pin of the 3.5 jack headers for AV-OUT on RF.A and RF.B. I don't use those for google obviously, but I use one of them for recording the stream to my phone (working as a DVR).

Anything else I could do to fix this, or do I need to fix this as well? I've got the recording working, but can't say if the issue is still present on the recording or is not affecting it.

Edited by Arise

Share this post


Link to post
Share on other sites

Applying a similar mod to the A/B (non-diversity) outputs would double-terminate the vRXs'  video signals. Unfortunately this would reduce the diversity's video level. 

 

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


×
×
  • Create New...