Jump to content
tbroeski

Loma hex file

Recommended Posts

I bought a nice melabs programmer that is listed as compatible for programming the 12C508A

There is no disable option, only input pin or reset:

conf3.jpg

conf4.jpg

Then the hex file shows up with lots of program lines, but when I read the chip after programming it only shows 8 lines are actually programmed.

prog1.jpg

prog2.jpg

Anyone know what might be happening?

I built a unit and it did not work properly.

tom-AT-inventorforhire.com

Share this post


Link to post
Share on other sites
Then the hex file shows up with lots of program lines, but when I read the chip after programming it only shows 8 lines are actually programmed.

http://www.rc-cam.com/faq.htm#pic_40h

I built a unit and it did not work properly.

http://www.rc-cam.com/faq.htm#pic_osc1

Share this post


Link to post
Share on other sites

Okay,

When I read the blank chip it comes up like this

read1.jpg

It hasn't asked me anything, but your instructions say to have it like this:

WDT: Disabled

MCLR: Disabled

Oscillator: IntRC

Memory: Code Protected

Share this post


Link to post
Share on other sites

When I read the blank chip the config file is:

0000 - 0fff

The config line in the hex file is

0000 - 0fe2

After I program the chip it is:

0000 - 0002

I'm at a loss....

And I read your previous post, but the programmer doesn't ask me anything.

T

Share this post


Link to post
Share on other sites

Once the hex file is loaded, confirm that the fuses are as shown in the screenshot below.

The OSCAL value treatment is another programmer setting. I have no experience with your programmer, so you will need to ask melabs how to prevent overwriting the PIC's factory installed OSCAL data.

post-7-1134259326_thumb.jpg

Share this post


Link to post
Share on other sites

Thanks

I will "check" update configuration from file

When I read the new chip the calibration file is

01ff- 0c7c

When I load the hex file it is blank. Is calibration the OSCAL data?

Melabs says the reason I can't read the chip after programming is that code protect is on. Can I turn that off until I get it right, so I don't have to keep building to find out?

Is there anything in "Options" you think I should check or uncheck?

Configscrn.jpg

Share this post


Link to post
Share on other sites

hate to say this.....

Had a darned old airtronics receiver with the positive on the end instead of the middle.

Switched to a Polk/JR and it worked....

Thanks for all the help!!!!

Share this post


Link to post
Share on other sites

Yup, that would make a difference. It's good to hear you sorted it all out.

By the way, as shown in your screenshots, the OSCAL programming feature is controlled by Options->Program->Calibration dropdown menu. You have it unchecked (disabled), which is correct for the project's PIC.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×